AMD Catalyst 13.2 beta 7 en Ubuntu 12.10 64bits

Publicado: marzo 10, 2013 en GNU/Linux

Captura de pantalla de 2013-03-10 16:23:16Saludos,

Quiero anotar en mi bitácora este proceso que ha funcionado por ahora (hace 10 minutos) bien y efectivamente la temperatura del equipo ha bajado sustancialmente y los drivers de mi AMD Radeon HD 75xxx series,  han quedado funcionando correctamente!.

Cabe mencionar que la guía que he seguido está en este link: http://ubuntuforums.org/showthread.php?t=2083181 (Solution to Ubuntu 12.10 AMD/Intel Hybrid Graphics not working) a quienes les agradezco mucho y que técnicamente hice un copia+pegar de esa página, solo que en español y uno que otro paso realizado por mi.

Preparando el equipo:

En consola ejecutar los siguientes comandos:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6
sudo apt-get install dkms libqtgui4 wget execstack libelfg0 dh-modaliases
sudo apt-get install linux-headers-generic xserver-xorg-core libgcc1

Si tu equipo es de 64 bits:

sudo apt-get install ia32-libs lib32gcc1 libc6-i386
cd /usr ; sudo ln -svT lib /usr/lib64

Descargar desde: https://launchpad.net/~andrikos/+archive/ppa/+sourcepub/2755647/+listing-archive-extra los siguientes dos paquetes, ya sea desde ppa o si los puedes descargar directamente:

xserver-xorg-video-intel-dbg_2.20.0-0~andrik1_XXX.deb
xserver-xorg-video-intel_2.20.0-0~andrik1_XXX.deb

donde XXX debe ser tu tipo de sistema (x86 o amd64).

[ así lo hice yo ]

En mi caso he realizado lo siguiente para poder instalarlos:

Agregué estos repositorios al archivo /etc/apt/sources.list

deb http://ppa.launchpad.net/andrikos/ppa/ubuntu quantal main
deb-src http://ppa.launchpad.net/andrikos/ppa/ubuntu quantal main

Y agregué manualmente la Signing key: 1024R/7C47A8C2 a mis orígenes de software de ubuntu. (la descargué e importé)

Luego actualicé el sistema: sudo apt-get update e instalé los paquetes así: sudo apt-get install xserver-xorg-video-intel*

[fin]

Luego debes ejecutar el siguiente comando:

sudo dpkg-reconfigure Xorg

Y luego reiniciar el equipo

Instalando:

Descargar desde la página de AMD Catalyst support el driver que esté en ese momento, en mi caso este:

http://www2.ati.com/drivers/beta/amd-driver-installer-catalyst-13.2-beta7-linux-x86.x86_64.zip

Lo descomprimes y lo haces ejecutable con: sudo chmod 755 amd-driver-installer-catalyst-13.2-beta7-linux-x86.x86_64.run y luego vamos a crear los paquetes .deb propios de nuestra máquina, así:

sudo ./amd-driver-installer-catalyst-13.2-beta7-linux-x86.x86_64.run –buildpkg Ubuntu/quantal

Luego los paquetes generados los instalas así:

sudo dpkg -i fglrx*.deb

Luego de la instalación:

Ejecutar el siguiente comando:

sudo aticonfig --initial -f

Y reinicias tu máquina.

Es todo!, si tienes algún problema en el link original de arriba puedes verificar mejor.

En mi caso he instalado previo a todo esto el entorno de escritorio gnome-shell y he podido verificar que efectivamente los Drivers está funcionando correctamente. Y puedo entrar a la configuración de ellos desde el menú, y además puedes verifcar la configuración ejecutando el siguiente comando:

fglrxinfo

Espero les funcione como a mi, que he esperado meses e intentado de todo para que esto funcione en mi equipo!

He aquí una imagen del resultado:

Captura de pantalla de 2013-03-10 16:25:24

 

Problemas presentados:

A pesar de ser ésta la única configuración que me ha servido, tengo los siguientes problemas:

1. Todo iba bien hasta que reinicié el equipo >> no funcionó el entorno gráfico.

Para solucionar esto, simplemente repetí los dos últimos pasos de la instalación, es decir sudo dpkg -i fglrx*.deb y sudo aticonfig –initial -f con esto en el siguiente reinicio ya mostró el entorno gráfico y funcionaba bien de nuevo. Eso quiere decir que seguí con el problema.

2. Solución temporal >> Cuando logres entrar con el entorno gráfico, iniciar el panel administrativo de Catalyst y en gráficos intercambiables, escoger los de Intel HD 4000. Con esto el sistema funciona correctamente aunque lógicamente estás perdiendo el poder de la tarjeta aceleradora. Pero para mi, esto le da posibilidades de aceleración gráfica normales y el equipo no se sobre-calienta al tener drivers “correctamente” instalados.

Quedo atento a una solución real y seguro la anotaré aquí, saludos!.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s